PAM unable to dlopen(/lib/security/pam_unix.so)

09.12.2007 0

La version stable de pam sous Gento (sys-libs/pam-0.99) nécessite de recompiler certains outils qui ne sont pas identifiables avec revdep-rebuild (shadow, vixie-cron, openssh, courier-authlib, cyrus-sasl etc.). Ce genre de problème se manifeste dans vos logs systèmes par ce genre de message:

Dec  9 00:00:01 aloyse cron[8986]: PAM unable to dlopen(/lib/security/pam_unix.so) <div>Dec  9 00:00:01 aloyse cron[8986]: PAM [dlerror: /lib/security/pam_unix.so: symbol pam_modutil_getlogin, version LIBPAM_MODUTIL_1.0 not defined in file libpam.so.0 with link time reference]</div><div>Dec  9 00:00:01 aloyse cron[8986]: PAM adding faulty module: /lib/security/pam_unix.so</div><div>Dec  9 00:00:01 aloyse cron[8986]: PAM unable to dlopen(/lib/security/pam_limits.so)</div><div>Dec  9 00:00:01 aloyse cron[8986]: PAM [dlerror: /lib/security/pam_limits.so: symbol pam_syslog, version LIBPAM_EXTENSION_1.0 not defined in file libpam.so.0 with link time reference]</div><div>Dec  9 00:00:01 aloyse cron[8986]: PAM adding faulty module: /lib/security/pam_limits.so</div>Dec  9 00:00:01 aloyse cron[8986]: Module is unknown

Utilisez qdepends pour trouver les packages à ré-émerger :

aloyse ~ # qdepends -Q pam<div>app-misc/screen-4.0.3</div><div>sys-process/vixie-cron-4.1-r9</div><div>sys-apps/shadow-4.0.18.1-r1</div><div>net-misc/openssh-4.7_p1-r1</div><div>net-dialup/ppp-2.4.4-r13</div><div>
Note: qpedends se toruve dans le package portage-utils

 Olivier PIERRE, freelance au Luxembourg Analyste développeur PHP/MySQL/jQuery et administrateur système Linux spécialiste Gentoo


Les messages similaires