Un autre joli bug Gentoo

25.11.2008 0

En mettant à jour votre serveur Gentoo récemment, vous avez peut-être rencontré l’un des ombreux cas de blocage généré par portage:


 Calculating dependencies... done!
[ebuild N ] sys-libs/e2fsprogs-libs-1.41.0 USE="nls" 476 kB
[ebuild U ] sys-fs/e2fsprogs-1.41.0 [1.40.11] USE="nls -static" 4,161 kB
[blocks B ]
sys-libs/e2fsprogs-libs-1.41.0)
[blocks B ] sys-libs/ss (is blocking sys-libs/e2fsprogs-libs-1.41.0)
[blocks B ] sys-libs/com_err (is blocking sys-libs/e2fsprogs-libs-1.41.0)

Surtout ne vous lancez pas dans lé désinstallation de ss et com_err ou votre wget ne fontionnera plus (entre autres)

Voici la solution pour contourner ce problème:


quickpkg com_err ss e2fsprogs &&
emerge -uDNf world &&
emerge -C com_err ss e2fsprogs &&
emerge e2fsprogs &&
emerge -uDN world &&
revdep-rebuild #(si nécessaire)

La joie d’utiliser Gentoo …


 Olivier PIERRE, freelance au Luxembourg Analyste développeur PHP/MySQL/jQuery et administrateur système Linux spécialiste Gentoo


Les messages similaires